This project is read-only.

Fortmating with WBFS

Nov 7, 2009 at 1:51 AM

So I bought a 1 TB western digital external hard drive. I have 800gb partitioned and formatted for my PC, and I partitioned the other 200 for my Wii.  I went to go format the 2nd partition in WBFS and it comes up with an error saying "an error occured while attempting to format the drive."


Does anybody know what may be the cause of the error?


Jan 29, 2010 at 6:19 PM

This just happened to me so sorry for delay. I am using Windows 7 Ultimate on my Sony Vaio laptop. Got the format error in WBFS manager 3.0. Problem was with my new Western Digital 1TB disk.

I initialized with Disk management in Windows 7. I noticed in EASEUS it showed as GPT disk and I could not access it. I went back to Disk manager in Wondows clicked on left part of disk definition at bottom and one choice was convert to MBR from GPT. Then Easeus could access. Set up 2 FAT32 partions and then WBFS could access. I had read that GPT are for disks larger than 2TB but I do not believe is compatible with WBFS. I have been working on this about 4 hours. Oh, I am using the 1TB on a USB o SATA connector. I don't think this has anything to do with it but for completeness wanted to include. Hope this helps some people.

Feb 9, 2010 at 4:38 AM
Edited Feb 9, 2010 at 4:48 AM

It seems to be a compatibility problem with Windows 7 64-bit (maybe 32-bit too). I was also having this problem and it worked fine when I tried it on a Windows XP machine.

Also, I found I could format it directly from the Wii using Configurable USB Loader, so you might want to try that.

Good luck!

Edit: After playing around with this some more, I was able to get it working by deleting all partitions off the drive, then creating a new MFT Primary Partition, assigning it a drive letter, but choosing to leave it unformatted. Then in WBFS Manager 3.0.1 I clicked Refresh Drive List, then Format and it worked.