This project is read-only.

For those who get errors trying to format USB HDDs in WBFS Manager:

Jul 9, 2013 at 1:41 PM
I had an old 250GB drive that I was trying to use for my Wii games. I finally realized it was giving me "an error occured" type messages when I tried to format because there was a small 200MB EFI partition on the drive that Windows wasn't getting rid of when I formatted it to NTFS.

To get rid of an EFI system partition you need to select the disk in diskpart and clean it. Afterwards, you can initialize it and then format it to NTFS in computer management. Google is your friend here.
Jul 19, 2013 at 9:20 AM
I did this and still doesnt work :( I even tried using ncWBFSTool.

Im using windows 7 x64 and 1TB Iomega external hard drive
Jul 19, 2013 at 4:02 PM
Did you have an EFI (or some other kind of reserved) partition on the drive to begin with? If not, then cleaning the drive in diskpart probably wouldn't have mattered.

The only reason I had to do so was because the 200MB EFI partition was preventing WBFS Manager from formatting the drive.

Your problem may have a completely unrelated cause. I hope you're able to figure it out.

On a slightly unrelated note, I was initially unable to get the installed Wii games on my hard drive to appear in USB loader GX via homebrew channel. If anybody else has the same problem, I restarted it, then tried again, but through the frontloader (which makes a 'shortcut' channel on the main Wii menu) instead of through the homebrew channel, and the list was instantly populated with the games on the HDD, and it now finds them even if I go to the loader through the homebrew channel. I also had to set the global video mode in USB loader GX to "disc default" as it was giving me a black screen whenever I started a game that didn't match my Wii's region.
Jul 19, 2013 at 6:30 PM
Ya I did Have an EFI partition and used command prompt to get rid of it which worked but WBFS manager still wont format my external hard drive :(
Jul 20, 2013 at 9:30 AM
Damn, that sucks man. Did you initialize and format it to NTFS after cleaning it, but before trying to format it in WBFS?

Sorry if I come off as asking stupid questions, I just have no idea why it worked for me and not for you.
Aug 17, 2013 at 12:45 AM
Hey Guys, I am having the same issue was zap... EFI partition, however i had already tried kyproith soliotuion ages ago, so i put it down to incompatiblitiy and changed drives. Until I had a Brainwave! I tried partitioning and formatting in win8 the first time with no success... Flipped back to and xp computer used a drive tool completely formatted to a true fat32.... Swapped back to win8 an ran diskpart/? accidently nada happen but when i tried wbfs manager format and it worked.
Jan 3, 2014 at 4:22 PM
here is another solution, probably the same i just got there another way.

tried the disk part......didn't seen to work, but i will say what i did.
select disk 1
delete part
delete vol
  1. so I went to disk management in win 8.1
  2. deleted volume.
  3. created a new volume.
  4. associated a letter to it. didn't format it.
  5. went into wb manager
  6. selected the new drive
  7. format.
Hope it helps.