This project is read-only.

How to fix Formatting error

May 17, 2012 at 5:45 PM

These are just 3 things to check which should make the error stop. This worked for me on 2 seperate computers and make work for you.

First we need to make sure your User Account for windows has Full Control of the file. As it is essentially a Partition manager you will need Administration Privledges to Format the Drive.

So make sure WBFS is closed, then Right-click the icon on the desktop and click Properties. From there click the Securities tab. Find the name in the list of User Names which you use to log into Windows. Select that User Account and make sure it has Full Control of the file.

If so, close the window, if not, search how to change user access permissions on the internet.

Next make sure you don't have any folders open like Windows explorer which list the drive as a link in the explorer bar. If you do not understand what I mean then close exerything except this internet page. If the drive is open anywhere by anything WBFS will not have suitable permissions for System to Format

Now Right-Click WBFS manager and click run as Administrator (very important in higher version of Windows when working with software which makes changes to your system). Once WBFS manager opens, Find the drive letter you want to format, select it in the drop down Menu, then click Format.

If it still does not work, make sure you have the right version for your system, IE 32-bit/64-bit. That should get everything running for you all.

Hope it helps some of you :-)

May 17, 2012 at 5:54 PM

Oh I forgot to mention I do not think it will work with a RAW drive, the drive must be formatted with something so ie NTFS, FAT32 ,FATeX. This is because a RAW drive with unallocated diskspace has no valid drive letter to select in the drop down menu.

May 18, 2012 at 4:20 PM

So I keep getting the same error when I try to format my HDD as well. I have tried all these steps and still has the error. Any other ideas?