This project is read-only.

wbfs-3.0 has encountered a problem & needs to close- HELP

Apr 3, 2011 at 3:31 PM
Edited Apr 3, 2011 at 3:47 PM

Hi, i had wbfs 3.0 set up fine on my p.c

P.C crashed, lost everything, recently downloaded WBFS 3.0 again in seconds, when i try to open it, it states "has encountered a problem and needs to close"

i cannot put any new games on my HDD. i really need help PLEASE!

i have tried installing the older wbfs 2.5, i get the same error.

i have even tried installing wii game manager, with the same result.

i believe net framework 3.5 is needed on win xp, so i installed that again, it didnt  help, so repaired that aswell.

6 hours researching on the web-no answers!

as this is the home of WBFS, does anyone have a helpful solution?



May 19, 2011 at 11:09 PM

i hope you get this in time after i replied this to a two year old thread in the issue tracker i saw your question.

do not install dot net fromework 3.5 (ever) or 2.0(before framework 3.5 sp1) 2.0 is hard to remove.

What i have been able to precipitate from my investigation on the issue is if you are ruing the program with the proper UAC (Administrator) than the issue is highly likely to be an issue with either corrupt files or the registry. I have found a solution that seems to work relatively well. It involves wiping<?sp? out all traces of .net framework in all versions. I have seen many cases where .net framework 2.0 took over and that was causing crashes. if you look in the system event logger after you try to run WBFS manager you will most likely see something to the nature of well here is a cut and paste. (from applications log file)
"5/17/2011 1:39:54 PM .NET Runtime 2.0 Error Reporting Error None 1000 N/A HOMEWORK Faulting application wbfsmanager.exe, version, stamp 49fe57d5, faulting module kernel32.dll, version 5.1.2600.5781, stamp 49c4f482, debug? 0, fault address 0x00012afb."
My purposed solution (all files can be found by Google or Microsoft's website)
For those out there that have problems getting WBFS manager to load after trying to re-install .net frame work 3.5 sp1 do the following
1. download as follows.
A. dotnetfx cleanup tool
B.Microsoft .NET Framework 3.5 Service pack 1 (Full Package)
2. run dotnetfx cleanup tool
3. leave the default selected ".NET Framework - All Versions"
4. click "Cleanup Now"
(it will take a while for the cleanup to complete)
5. REBOOT! after the cleanup has completed
6. install Microsoft .NET Framework 3.5 Service pack 1 (Full Package)
7. REBOOT!! (yes again it is necessary)
8. install the latest version of WBFS manager
10. help others with the same process.
un-install .NET Framework 3.5 Service pack 1 firs

May 19, 2011 at 11:11 PM

only install dot net 2.0 if there is a reason you need it you have no idea the amount of issues it causes.

May 21, 2011 at 11:02 AM

Redwarlock, Thank you for taking the time to respond, fortunatly i had an e-mail notification letting me know i had a reply to my post.

As stated above a unfortunate event crashed my tower, and i lost everything, had to reinstall op system and start from scratch-so i think the net framework either came from automatic updates, OR I suspect the framework 3.5 was specified as a potential fix, by another wbfs manager user from a different thread having the same problem, so I may of tried that solution as it had worked for them.

your fix, suggestion- I will try in the next few days. if it is successfull I will reply.